博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
POJ 2387 Til the Cows Come Home(Dijkstra)
阅读量:4677 次
发布时间:2019-06-09

本文共 1995 字,大约阅读时间需要 6 分钟。

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.
Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.
Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N
* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 51 2 202 3 303 4 204 5 201 5 100

Sample Output

90 //简单的Dijkstra使用,没有其它技巧,可以用来熟练模板、、、想学堆优化!!!!

#include <iostream>

#include <stdio.h>
#include <string.h>
#define N 1003
using namespace std;
int p[N][N];
int main()
{  //freopen("in.txt","r",stdin);
    int T,n,i,j,min,x,y,cost;
    bool f[N];
    while(scanf("%d%d",&T,&n)!=EOF)
    {
       memset(f,0,sizeof(f));
       for(i=1;i<=n;i++)
          for(j=1;j<=n;j++)
             p[i][j]=0xffffff;
      for(i=0;i<T;i++)
      {
          scanf("%d%d%d",&x,&y,&cost);
          p[x][y]=p[x][y]<cost?p[x][y]:cost;
          p[y][x]=p[x][y];
      }
      f[1]=1;x=n-1;
      cost=0;
      while(x--)
      {
          min=0xffffff;
          for(i=2;i<=n;i++)
            if(!f[i]&&p[1][i]<min)
            {
                min=p[1][i];
                j=i;
            }
            f[j]=1;
         for(i=2;i<=n;i++)
           if(!f[i]&&p[j][i]+p[1][j]<p[1][i])
              p[1][i]=p[j][i]+p[1][j];
      }
      printf("%d\n",p[1][n]);
    }
    return 0;
}

转载于:https://www.cnblogs.com/372465774y/archive/2012/04/22/2464765.html

你可能感兴趣的文章
SEO页面优化
查看>>
读构建之法第一天
查看>>
Redis(二)、Redis持久化RDB和AOF
查看>>
浅谈OC内存管理
查看>>
关于TortoiseSVN的一些知识
查看>>
mysql优化
查看>>
Node.js Web 模块
查看>>
Factory Method(工厂方法)
查看>>
英语口语考试资料Language learning
查看>>
关于TreeSet倒序排列和自定义排列
查看>>
CodeForces 234Div2
查看>>
Vim笔记
查看>>
5.python的字符串
查看>>
操作系统笔记(一)介绍
查看>>
转-- 介绍 Java 自带的线程池(2)
查看>>
RabbitMQ Lazy Queue 延迟加载
查看>>
解决“您当前无权访问该文件夹”的问题
查看>>
Myeclipse快捷键集合
查看>>
URLEncoder和URLDecoder转码
查看>>
STL.Net
查看>>